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DesignExpert 8 Kurzeinfuhrung

Jedes Projekt kann aus mehreren Dateien bestehen:
Im Projektnavigator (Abb. 2)

werden alle zum Projekt Projekt

gehdrenden Dateien verwaltet. / *.syn

Eine Datei kann in mehrere /

Projekte einbezogen werden. Text-Datei in Text-Datei in Zeichnung Zeichnung
Oft wird ein Projekt jedoch nur Abel-Sprache Abel-Sprache

eine Quelldatei als Text oder * abl * abl *.sch *.sch
Zeichnung enthalten.

Wichtig: Die zum Board Abbildung 1

Uberspielte Datei trdgt den Namen
des Projektes mit der Endung .jed (Jedec-Datei)

1. Projekt (*.syn) und Datei (*.abl) anlegen

File -> New Projekt, Projektnamen BispDesignE xpert Project Navigator - [C:AEIGENE DATEIEN\ISP10.... [BI[E] B3
ile “iew Sowce Process Options Window Tools Help

vergeben =

g N [~ u %lateg,vl j

Processes for Current Source:

DOppe| kI|Ck, -ﬂ =i [Mo Processes Available)
Projektname oder Beschreibung ~ Eiﬁfég‘g‘ﬁ’w““
§Ielecl thﬁ e S button ta add SdD;lfce ar Mo Déacekssgs Iale avai\ﬁble_ for t_hehpmiecl
DOppe|k|IC|(, mport..." if e Source menu to add from an goolfmoeohs.t toageaftp.ragco;s:;;t.em inthe
Bauteilname aus Liste suchen — o o] i oo |
Source -> New Abbildung 2
Abel-HDL Module fiir Texteingabe in Abel- —
Sprache Hinweis zur Namensvergabe:
Schematic fir Schaltung zeichnen ::e'_“ Lerllrz_elchen, kein Umlaut,
Module Name und File Name gleich wahlen €in —, xein _,
Tital « inkhin cindeacanlll lange Dateinamen erlaubt
/
/ 2. Eingabe in der Abel-Sprache
Aufruf des Editors aus dem ¢ Text Editor - [led.abl] [_ O[]
ProJeCt NaVIgator : File Edit View Templates Tool: Options Window  Help _|E|i|
Doppelklick auf = . -
nl==
SchlUsseth')rter, die ganz MODULE LED "Modulname = Dateiname wahlen =
bestimmte Funktionen haben: "#xx Einschalten einer LED mit Hilfe eines Schalters *xsxxxxx —

werden automatisch  blau

dargestellt und kt')nnen grOB DECLARATIONS "*®%%%e%%®%%%%% Fin— und AUSgANge %%EEEEEEREERENRE

oder klein geschrieben schalter PIN 19: "Schalter an Pin 19
werden led PIN 7 ISTYPE'BUFFER COM':"LED an Pin 7.
.. "Ausgang chne Flipfleop

(Im Beispiel rechts groR _
geschrieben) EQUATIONS Anweisungen

N . led = =schalter; "Schalter=ztellung ausgeben
Zur besseren Ubersicht sollte END
der  Programmtext etwas _Ij
eingeriickt stehen. 4 | y
Bei Pin-Namen und [Cn3CalE2 [ 18 [# [wR Fec Off [No'wiap [DO5 [IN5 [MOM [
Variablen-Namen wird Abbildung 3
zwischen Grof3- und e

Kleinschriebung unterschieden!
Schalter # schalter, LED # led.

Kommentare beginnen mit * oder // und werden automatisch griin dargestellt

Alle diese Angaben sind Teil der ABEL-Hochsprache (HDL = High-Level Desciption Language).
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3. Ubersetzen (Compilieren)

Erstellte Abel-Datei anklicken, BlispDesignE xpert Project Navigator - [C:\EIGENE DATEIEN\SP1016PAKE...

dann wird im rechten Fenster File %iew Source Process Options Window Tools Help

dargestellt, welche Aktionen mit D= =] strategy[nomai =l 2|2

dieser Datei durChgerhrt Sources in Project: Processes for Current Source:

werden kbnnen: —\ E Schalterstellung an LED ausgeben ‘RHierarchy Browser
£3ispLsI1016-60L)44

= & Compile Logic
Zum Ubersetzen Doppelklick LED { I ; {3 Check Syntax
Bei Fehlern: By Compiler Listing

By Compiled Equations
Fehlertext lesen 8 “erilag Test Fidure Declarations

Datei Wieqer '('jffnen [BvHOL Test Bench Template
(Doppelklick links auf X Reduce Logic
Dateiname) BiFeduced Equations

Wenn fehlerlos erscheint ein
griner Haken vor Compile Logic

Double-click the item in the list or select the “Start™
button to start the process. Select the "Properties..."'
button to start the property editor.

ﬂl ml Properties...l Log...l

Logik minimieren

Abbildung 4
4. Logik auf den Baustein |
anpassen
M ispD esignE xpert Project Navigator - [C:AEIGENE DATEIENMSP1016PAKE =] B3
auf den Bauteilnamen klicken Eile gfw Souce Process Options  wWindow ;Dls ﬂelp‘?
rechts erscheinen die D= ] Stratogy|ramal =1 = [=21M)

Sources in Project:

maoglichen Aktionen:

Bl Schalterstellung an LED ausgeben
B:isplSI1016-60L.J44 i

B)Linked Equations

[FILED {led.abl) : 2 Reduce Logic
- - . = EDIF Metlist
Projekt aus einzelnen Dateinen ], Constraint Manager
zusammensetzen. G Compile Design

8 JEDECFile
R compiler Report

. . 3T Anal
Projekt auf den gewahlten S Timing Explorer
Baustein anpassen. Bl Meximum Freguency Peport

B Setup/Hold Report
R Ted Repont

Programmieren des Bausteins ,{EF',IC? Peport
0 I wsical Wiewear
(Herunterladen) | ISP Daisy Chain Download
D ouble-click to choose a different device. D ouble-click the item in the list or select the “Start™

button to start the process. Select the “'Properties..."
button to start the property editar

New...I Dpen...l Staltl Viewl F'roperties...l Log...l
Ready
Abbildung 5
5. Baustein programmieren |
(Download)

ELSE ISP Daigy Chain Download Version 8.0.1

Board anschlief3en und Ver- Fiie Edit Configuration Command Help
bindung zum PC herstellen. el N A s R e e e WA s F L M R E
mit Scan_BUIton feStSte”env E Sean Poard Configuration Se/up®
WeIChe Bausteine Uber das Ingfx Devices Ffle NamefInstruction Bits Checksum Operation  Status
D_O;anoadkabel erreichbar ), SDI ISP Chain Interfage | Comment: H ‘
Sind.
%%“1015 =] | Brgwse [ C:\EIGENE DATEIENUSP1016F ][] [lrv ZI[ WA ]
Diese Meldungen
. SDo
arcrhoinon AN ~
- - “‘Me“ages
Jedec-Datei suchen, die Al
den BaUSteln Chain Detected. |

programmieren soll. —

Yz
Run Operat|0n For Help. press F1 I_WI_ p
Download ausfiihren. Aohilduna 6

(oder: Command -> Run
Operation)
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6. Funktionale Simulation (Beispiel: UND-Verknupfung)

Zunachst sind unter
dem Abel-Text
sogenannte
Testvektoren
anzugeben:

Nach dem
Abspeichern der
Datei erkennt
DesignExpert die
Testvektoren und
fugt im
Projektnavigator die
Madglichkeit der

Simiilatinn hinzi

IHODUT_E THD "xxx% THD-Verkniipfung zweier Schalter

DECLARATIONS "#%x%* Angabe der Ein— und Ausgange

=in?, einl PIH 19, 21; "Eing&nge: Schalter

aus PIN 3 ISTYPE 'BEUFFER,COM': "Ausgang chne Flipflop: LED
EQUATIONS "#x%% logizche Verkniupfungen

aus = ein? & =inl; "THD-Verknupf ung

TEST_WECTORS "#*%*%x Simulations-Yelktoren

"Festlegung der zu untersuchenden

{([ein2. einl] -> aus): "Eingange —» Ausgange
"zu simulierende Kombinationen folgen
[ O 0 ] - ®. "beide Eingange 0 —-: Ausgang don't care x.
[ o0 .1 ] —» .= "ousw.
[ 1 .10 1] —» .=.:
[ 1 1 ] - ®.:
END d|

EispDesignExpert Project Mavigator - [C:A\EIGEME DATEIENASP1016PAKE .. M=l E3

File “iew Source Procesz Options  Window Toolz Help

Doppelklick:

StrategleormaI 'I

Testvektoren Ubersetzen

Sources in Project:

Processes for Current Source:

Bl UND-erkniipfung

Doppelklick zur funktionalen
Simulation ohne Beachtung
der Gatterlaufzeiten.

ispL=1016-60LJ44
x UMD-vectors

[+ & Compile Test Vect
[Z) Compiler Listing
) Lv & Functional Simulation

[A)UND {und.abl) LAY & Timing Simulation

L B N N DU T TS T}

Doppelklick zur Zeit-

bausteinspezifischen
Gatterlaufzeit

Simulation mit Beachtung der

Y Y P R

Abbildung 7

e gups Gradie Yew [ g
Wl [ oyl | by [ Eicg itcrenl: [iifns | Aenie Tieel [$00.0 00
IWYIALoT . VACEL

Simulation starten

a o1 -
sERlAE S 5l BT preoped e
. -~ d
Faireg
*

Edit->Show

um eventuell weitere
Signale anzeigen zu
lassen, die nicht
automatisch dargestellt
werden

Uber Bus lassen sich
mehrere Signale

Unter View finden sich
Zoom-Mdglichkeiten

B Waveform Viewer - UND =]

File g’dit /Eiew Object Toolz Option: Jump Help

/[ vans O 200 400

EINZ |
EIN1

Mit Hilfe der Timing-
Simulation wurde eine
Signal-Laufzeit vom
Wechsel der
Eingangssignale bis zur
Anderung des
Ausgangssignals von 20
ns gemessen.

AUS
4 I3 KR _>|_I
Time = 0.0 ns
Abbildung 8
B Waveform Viewer - UND _ O]
Fle Edt “iew Obect Took Option: Jump Help
0.0 ns 2 200 400
L1 1 1 1 1. | | I | L1l |
EIN2 | e
1 EIN1
AUS
q K R f

Time = 320.0 ns - Delta = 20.0 ns Strong 0 - Simulation-States
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7. Vorhandenes Projekt unter neuem Namen speichern

Das Projekt ,Alt" wird unter dem Namen ,Neu*“ gespeichert.

1 Im Project Navigator: File -> Save As

Save Project As HE
EispDesignExperl Project MHavigator - -
Wiew Source Process Ophions W v SPEiChem.in:ID IEp j | ﬁl I |
Hew Project. ..
At

Open Project...
Dpen Example... yl=t]
Cloze Project

Save i
2 Neuen Ordner anlegen Dateinsse W [neufson | Bfinen_|
Ordner wie Projekt nennen % Fea i Cor) = |
Projektnamen angeben

Es folgen 2 Abfragen, die beide mit Ja beantwortet werden, daraufhin wird auch die
»+Abel-Datei" *.abl mit ins neue Verzeichnis kopiert.

3 Abel-Datei umbenennen: Bl ispDesignExpert Project Navigator
auf Name klicken R Fil= Misw Process  Options %
= Mew... _
Import... m ! Mew. .

Sources i

Dpen

Source -> Remove

Sources n Trew

E UND- Eemove

Strateqgy. ..

Shrategy...
B alt (alt.abl)

Source -> Import

)
Im Offnen (Import)-Fenster Suchenin | =3 nen = =T

Datei umbenennen nach

Al
Klick mit rechter Maus auf =) e—
den Namen R

Ausschneiden
Kopieren

Veknliphung erstelen
Lbschen

umbenannte Datei 6ffnen — P ot

Ejgenschatten

D ateinarme: Ialt.abl w
D ateityp: I Sources [ abl;.schzaby;...) LI Abbrechen |

EispDesignExnell Project M3

File “iew Souce Process 0O

4 Nach Doppelklick auf ~ ——— [C=]E] stateay|emal
im Editor hinter Module auch séulrj;s[;n\fmrct ;
den neuen Namen eintragen iepLSI 016080144
und Datei speichern. B altvectars

& Ordner  Prajekt

Kontrolle: 4x der neue Name!

File “iew Source Process  Option: Window  Tool: Help \_/
Iﬂm StlategleormaI j

Sources in Project: Proceszzes for Cumrent Source:
Bl UND-Verknuepfung Hierarchy Browser

£)ispLSI1016E-80LJ44 i Compile Logic
B8 3 Check Syntax
[ByCompiler Listing
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8. Grafische Eingabe mit selbst erzeugten Grafik-Symbolen (ab DesignExpert 8.1) |

. 1 *
Ausgangspunkt' ZB 3 Abel Date_len ( abl) X MODULE RS_FF "Highaktives RS-Flipflop mit einem Ausgang
(Pin-Nummern nicht nétig, stéren aber auch nicht, DesignExpert nimmt
= . . L . h DECLARATIONS "#%%#xx%sx% Fin- und AUSQANgE FEFFEEREEETEELREELHE
spater die Pins, die in der Zeichnung angegeben sind.) 9ang
S, R PIN ; "Eingange RS-Flipflop
MODULE bin7seg "Codeunsetzer 8-4-2-1-Code -» 7-Segment-Code (1] PIN ISTYPE'BUFFER,COM™; "FF-Ausgang O
DECLARATIONS " #=xsswwsswsswss Ein- und EOUATIONS
dg,d4,d2,d1 pin; _ Lo : : : _
a.b,c.d.e,F.g pin ISTYPE BUFFER.COM" ;"7 Segn-Anzeige 0 = IR & #0; "ricksetzdoninates highaktives RS-FF
dualzahl = [d8,d4,d2,d1]; "Dualzahl END
segnent? = [a.b,c.d.,e.f.gl: "'7-Segment-Anzeige
TRUTH_TABLE "##*#%%% Funktionstabelle 8-4-2-1-Code -» 7-Segment-Code MODULE ctrdivlo "Zahler 0 bis 9 mit Freigabe (= auch Ubertragseingang),
"Ubertragsausgang und asynchronem Reset
{dualzahl -> [a ,b ,c ,d ,e ,f ,g 1) "Eingange -> Ausgange ldeclarations
- [1.,1,1,1,1,1,0]; LEDs hrigh-aktiv! C,Freigabe,Reset pin; "Eingange
1 -=[0.,1,1,0,0,0,0] a 01,02,04,08 pin istype 'buffer,reg”; "Ausgange mit D-FF
2 -~Mm1m,1,0,1,1,0,1] --- t9 pin istype 'buffer,com”; "Ausgange ohne D-FF
3 -=Mm,1,1,1,0,0,1] flglhb Cctr = [08,04,02,01]; "Zahler aus 4 FFs
4 -=Mo.,1,1,0,0,1,1] o
5 -»Im,,1,1,0,1,1] eld]|c lequations
6 - m,,1,1,1,1,117; -—- when Freigabe then { when Ctr.q == 9 then Ctr.d = 0; "Rilcksetzen bei nachstem Takt
7 -=[Im,1,1,0,0,0,0]; else Ctr.d = Ctr.q +1; "Zahlen
8 -=[,1,1,1,1,1,1]; I
9 - [1,1,1,1,0,1,1] else Ctr.d = Ctr.q; "Stehenbleiben
10 -0n,1,1,0,1,1,1];"A Ctr.clk = C; "Takt fur alle Flipflops
1 =0, ,1,1,1,1,1];"b , ;
12 -~ [0 .,0,0,1,1,0,1];"c when (Ctr.q == 9) & Freigabe then Ct9 = "Ubertrag und Freigabe nachste Stelle
13 =0 ,1,1,1,1,0,1];"d else (19 = 0;
14 [, , ,1,1,1,1];"E : .
15 ~~[.,0,0,0,1,1,17 F Ctr.ar = Reset; asynchroner Reset
END END

Im Explorer: Ordner fur neues Projekt anlegen,
gewiinschte Dateien *.abl in den Ordner kopieren.
Datei allelOs.sch (alle Pins der Platine fertig gezeichnet, im Ordner allelOs) in den
Ordner kopieren und umbenennen, (so wie das Projekt heif3t).

In DesignExpert: Projekt anlegen,
mit Source -> Import werden die Abel- Dateien zum Projekt hinzugefigt

Sources in Project: Processes for Current Source:
Bl Feaktionstester A, Hierarchy Browser

e e M:EABELestﬂorTemplat <_ DurCh DoppelkIICk:

[FYhin7seg (hin7seg.akl

:trd\v1ﬂ(ctrd|vﬂ]abl) GOC;I:;,;IESL;?::X Symbole erzeugen von
B Sompied B jeder Datei *.abl

i@ verilog Test Fidure Declarations
@VHDL TestBench Template
G Feduce Logic

[RReduced Equations

mit Source-> Import wird die Schematic-Datei (s.0.) hinzugefugt und durch Doppelklick getffnet:

#% Schematic Editor - ALLEIOS - Sheet 1

File Edit View Add Tools DRC  Options Help &

DelE] & &l = P 2lE Cl=E =8 ] 21

EINF SEG 7-Segment-Anzeige rechts
Tasten [T [i6] {4 - o
} T1 b Edge fbr>
e [] e
TaﬂerQ —[2a > .> | 4 ?
o s =~z 7 L
= — =r
Schalteﬂ —[ETa— 81 =—d8 1l %ﬁ—@
} 51 14 i — gr far
&h;nerz —EE— [ese BIN7SEG 7-Segment-Anzeige links
N [EZh> o a [ 4]
L SZ2b b 3 B
4 Schalter — — bl
H—"— E——{z= i & e D
- 5] =3 o d 7
H T 727 =% . — 4l .
H—"— B 27 |+ a|da | 5 [
_ (25 | S5 a—]d3 1l 9 |—r>
H T EC1 g RS (10} f
4 Buchsen - - abe | =— 13 g —gl_@
s e =)
3z O—[E2 _£_>E_3Eé Eni k= 4 Buchsen
E/az1 O—[E3T —— 31 _
=1 E31 i |3 o]
Etazn O—E30——{30 [+ e, — 2| —C Eazz
Efm29 O—/(E295—— 29 [+ =5 Al~IO = Elll ren EXi —2 /A3
als Eingange benutzt! SNE R = 30 [-=gla30 > —O E/A30
= |29 | amgl®28 > —( E/A29

als Ausginge henutzt
alle nicht benétigeten Pins entfernen, sonst sturzt DesignExpert spater ab!
Entfernen: Edit->Cut oder Schere-Button, Fenster bei gedriickter Maus Uber zu entfernenden
Teilen aufziehen oder Anklicken der Bauteile. (Riickgéngig gibt's auch)

Carl-Engler-Schule, Karlsruhe AnleitungDesignExpert.doc
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falls Drawing Toolbar nicht sichtbar: T e

File Ecit PP &dd Tools DRC Opti

| I B,—»I B Zoom In Crl+l
T mn er BINTSEG
PBan Ctrl+has at
e CTRDVTO ol
v Main Toalbar
{Reset o
Freigabe
) i 1 aib 191 dr
Eigene Bauteile holen: 5 O |
Sl Library Q4 Hd4
gl {d8 ft
C:h AGEMERICVGEMERICWMISC
ﬁAdggyn%l C:AAPLSINPLSINARITHLIB 3 ar
= Ch. APLSMPLSBCODERLIE =l 16 14
Rl /
a2 [ I Swmbol gS_FF
Bin7 «— i ile! Q
Al O binseg eigene Bauteile! =¢
~| ol rs_ff 17
I
[Drawing E3|
Plazieren, eventuell verschieben = :i il = verbinden , speichern,
fertig. S P N T
AR ES ful® |
= o2 1 ez
AN ANO
~[ol@ IR ISIES

Im Projekt-Navigator wie gewohnt Gbersetzen und downloaden.

Die oben erzeugten Symbole sind in den Dateien *.sym im Projekt-Ordner gespeichert.

Eine eigene Bibliothek mit eigenen Bauteilen erzeugen sie wie folgt: (aus der Online-Hilfe)

Using Symbol Libraries in Your Design

Once you have created a symbol library, you can access it from the Schematic Editor. A
library, in order to be accessible to the Schematic Editor, must be added to the search

path of your project.

1. In the Project Navigator, choose Options _ All Schematic to open the INI Editor
(Schematic Environment dialog). Then click the Symbol Paths tab.

2. Click Browse and go to the location of the library that you want to add. The path
appears in the Path field.

3. To add the path to the symbol library search path, click Add. The path appears at the
top of the search path list.

4. You can use the other buttons on his dialog to delete a path from the list, or to move a
path up or down the search order.

Adding the Symbol to a Library

After you have saved the symbol, you can both leave it in the local design directory and
add it to the schematic from this location, or you can add the symbol to a Symbol
Library for use in other designs.

1. In the Project Navigator, choose Window __ Library Manager.

2. Choose File _ Open and open the library.

3. Choose Edit _ Add Symbol to open the Add Symbols to Library dialog.

4. Go to the location of the symbol that you want to add and select it. Then click Open.
ispDesignEXPERT adds the symbol to the library.

Carl-Engler-Schule, Karlsruhe AnleitungDesignExpert.doc
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9. Graphische Eingabe bei Synario und DesignExpert

Aufruf des Schematic-Editors vom Project Navigator: Source => New, Doppelklick auf Schematic
Fenster Drawing: View->Drawing Toolbar

+4 Schematic Editor - [Untitled] - Sheet 1 of 1
File Edit “iew Add 0Object Option: Toolz: Help

I_I_I_Ilﬂil@ll_l_ll_llﬁlﬁlml_ll_ll_lﬁll_ll_l

‘Zoom In ‘ ‘Zoom out

‘Bauteil plazieren ‘ Verbindungsleitung

Bauteilname ‘IO-Marker ‘

‘Pin-Nummern ‘ ‘Netzname ‘

Loéschen, Bauteil oder

markiertes Feld
‘Bauteil spiegeln ‘ -@.

K Kurzer_klaru g des gerade aktiven Befehls _,|—I
Select A Command. " loder Eingabefeld

Bauteil kippen

Abbildung 9

Vorgehensweise bei der graphischen Eingabe

Alle diese Schritte sindin dieser Reihenfolge nacheinander auszufiihren.
Siehe auch Beispielschaltung Abbildung 11 + Symbol Libraries

LIBRARY

[Local) =

C:% _AGENERICAMISC

1. Bauteile plazieren:

Add => Symbol, es 6ffnet sich nebenstehendes Fenster. /’ [T\ AGENERICAIDPADS.LIB
Bibliothek wahlen, Bauteil wahlen YN m&g
Bauteile auf dem Blatt plazieren durch linken Mausklick. aNDI1

Ende: rechter Mausklick. anols

Mdglichst alle Bauteile an der richtigen Stelle plazieren, erst am ANDIE

SchluR verbinden. ANDIS

Wichtig: Alle Verbindungen nach auBen (IC-PINs) miissen mit AND3 =l
IO-Pads versehen werden. (Bibliothek IOPADS) Abbildung 10

2. Verbindungsleitungen herstellen:
Add => Wire Kilick Leitungsanfang, Leitung ziehen, Klick Leitungsende
Ende rechte Maustaste oder wenn Leitung am Bauteil endet.
Es durfen keine offenen Leitungsenden entstehen.
(Ausnahme: Ubergangsstellen zu Schaltungsteilen in anderen Dateien, die spater mit einem
IO-Marker versehen werden)
An die IOPADs sind von aulR3en kurze Leitungssticken zu hdngen (weil sonst die spatere
Beschriftung nicht richtig funktioniert.)

3. Bauteilnamen vergeben:

Add => Instance Name, in der unteren Fensterzeile erscheint der eingegebene Name

Name schreiben und mit der Maus auf das Bauteil plazieren.

Alle IOPADs miissen einen Namen bekommen andere Bauteile kdnnen einen erhalten.
4. Netznamen vergeben:

Add => Netname, in der unteren Fensterzeile erscheint der eingegebene Name.
Carl-Engler-Schule, Karlsruhe AnleitungDesignExpert.doc
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Name schreiben und mit der Maus auf der Leitung plazieren.
Alle Leitungsenden auRBerhalb der IOPADs mussen einen Namen erhalten , andere wichtige
Leitungen kdénnen einen Namen bekommen.

. I/O-Marker setzen:
Add => I/O Marker, Input oder Output wéhlen.
Mit der Maus an das Ende der Leitung, Klick, und bei gedrtickter Taste Uber die
Beschriftung nach auf3en ziehen.
Es entsteht ein Pfeil Din dem der Name des Netzes steht.

. PIN-Name vergeben:

Edit Symbol Attribute, es 6ffnet sich dieses : Symbol Attribute Editor
Dialogfenster. OptimizeLocally |

Auf das I/0-Pin in der Schaltung klicken , GoTo | [

im linken Fenster erscheint der I/O-Pin-Name, Instances I™ List All Attributes
rechts SynarioPin wéhlen, QptinizeLoce

im Eingabefeld statt em Stern die gewiinschte Clock_Type="
Pin-Nummer eingeben, nochmals auf das I/0-Pin PLS1_SymAtt=

klicken.

Nun kénnte die Schaltung so aussehen: .
Abbildung 12

Schematlc Editor - 2AU53 - Sheet 1 of 1

FI|E Edit “iew Add Object Optionz Toolz Help

N EEBBEEEEEREEE EEEEIEIEE

[Dwaktve 2-aus-3-5chaliung

i 12 —|>Em1 5 E>ﬁ N1

OR1

nz ;
E— — 9 aus
— NOR2 ﬂom au
— & na
_|>Elr'|3 —

MOR3
4] _"I_I
Zoom In - Pick Center Point or Curnt:r of Zoom Window

oy , m
3 >
(5] B
—
(a5
Ly
=
Fa

Abbildung 13

I/O-Marker mit I/0O-Pad mit NOR-Gatter mit Netzname
Netzname Bauteilname und Bauteilname
IC- Pin-Nummer

Editor verlassen, im Projekt-Navigator Schaltung compilieren. - Viel Gliick und Ausdauer!

10. Funktionale Simulation bei grafischer Eingabe

Carl-Engler-Schule, Karlsruhe AnleitungDesignExpert.doc
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» Schaltung zeichnen.
* Source => New

@ISP Synario System Project Navigator - 2ZAUS3.5YN

Abel Test Vectors wahlen.

Dateinamen kdnnen gleich
dem Dateinamen der
Schaltung sein.

» Testvectoren wie im
Beispiel unten eingeben.

» Compilieren

File—ttege Source  Process

Dptions

Tool:  Window  Help

5tlateg}'| Normal

Bl

Sources in Project:

Processes for Current Source:

[l 2aus3
£d ispLSI1016-90 TOFF44
2aus3.aby
[£] 2aus3 (2ausd.sch)

» Ergebnis ansehen

Wl Compile TestYectors
Compiler Listing

& 33 Simulate Equations

4 Equation Simulation Repart

v CJEquation Sirmulation YWawveform

Diouble-click to oper the selectedTest
WECtors.

New...l Open...l

Criouble-click the item in the list or zelect the 'S tart
buttan to start the process. Select the "Properties..."!
buttan to start the property editar,

Stanl ‘-'iewl Prupenies..l Lug...l

|Rieady

Beispiel einer .abv Testvector-Datei fur die in Abbildung 14 dargestellten Schaltung.

MODULE zweiaus3;

DECLARATIONS

aus

EQUATIONS

TEST_VECTORS

einl,ein2,ein3 PIN 12,13,14;
PIN 9 ISTYPE 'COM';

"Testvectoren fur die 2aus3-Schaltung

"Namen und Pin-Nummern wie in der Zeichnung ****¥xxkkrkix

"Testvectoren fur die Simulation. Diese konnen in dieser

"Schalter und LED sind lowaktiv.

"Test-Vector-Datei *.abv angegeben werden.

([einl,ein2,ein3] -> aus);"3 Eingange, 1 Ausgang.
@const i=0; "Festlegung der Zahlvariablen
@repeat 16 { i .X.; "in {} folgendes 16 mal wiederholen
@consti = i+1; } "dabei Zahlvariable um 1 erhéhen
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END
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